728x90

원문출처 : https://svrforum.com/os/289851

 

서버포럼 - Proxmox local/local-lvm 디스크 통합하기

안녕하세요. 달소입니다. 요즘 계속 Proxmox에만 집중하고 있더니 이것저것 새로운게 많네요 ㅎㅎ 이번편은 Proxmox를 최초 설치했을때 파티션이 분리되어있는걸 통합하는 방식입니다. Proxmox를 최

svrforum.com

 

이번편은 Proxmox를 최초 설치했을때 파티션이 분리되어있는걸 통합하는 방식입니다.

Proxmox를 최초에 설치하고 나면 LVM의 파티션은 아래처럼 구분되어있습니다.

 

제기준으로 8TB HDD

Local - 100G (PVE/ISO/템플릿 등 용도)
Data - 나머지 7.xx TB (VM Disk/CT 볼륨 용도)

 

이렇게 나뉘어져있습니다.

제일 불편한건 로컬용량 자체가 100G로 보여서 쉘에서 작업할때 용량이 제한이 있다는거겠죠..

 

그래서 이 local-lvm을 기존 local에 통합시켜버리도록 하겠습니다.

통합을 하기위해서는 기존에 사용하던 스토리지를 아예 깔끔하게 비워주셔야 합니다.

그리고 쉘로들어가서 아래와같은 명령어를 입력해주세요.

명령어 내용은 위에 캡쳐한 data를 지우고 그용량의 전체를 /dev/pve/root로 리사이즈 시켜준다는 의미입니다.

 

lvremove /dev/pve/data
lvresize -l +100%FREE /dev/pve/root

 

 

리사이즈가 완료되면 /dev/pve/root의 파일시스템도 리사이징 해주시면됩니다.

 

resize2fs -p /dev/pve/root

 

 

완료되면 local의 토탈 사이즈가 늘어난걸 확인하실 수 있습니다.

 

마지막으로 스토리지로 가서 local의 디렉토리에 콘텐츠를 추가해주시면 됩니다.

 

728x90

참고 사이트 - https://hub.docker.com/r/adguard/adguardhome

 

Docker Hub

 

hub.docker.com

version: '3.3'
services:
    adguardhome:
        image: adguard/adguardhome
        container_name: adguardhome
        volumes:
            - './work:/opt/adguardhome/work'
            - './conf:/opt/adguardhome/conf'
        ports:
            - '53:53/tcp'
            - '53:53/udp'
            # - '67:67/udp'    #DHCP Port(사용시 주석제거)
            # - '68:68/udp'    #DHCP Port(사용시 주석제거)
            - '80:80/tcp'      #설정UI Port(HTTP)
            - '443:443/tcp'    #설정UI Port(HTTPS)
            - '443:443/udp'    #설정UI Port(HTTPS)
            - '3000:3000/tcp'  #설치시 초기셋업 Port
            - '853:853/tcp'
            - '784:784/udp'
            - '853:853/udp'
            - '8853:8853/udp'
            - '5443:5443/tcp'
            - '5443:5443/udp'
        restart: always
728x90

DNS over HTTPS(DoH)용 테스트 사이트 - https://1.1.1.1/help

 

 

 

728x90

맬웨어(Malware) 감지를 위한 테스트 사이트 – https://www.wicar.org/

 

WICAR.org - Test Your Anti-Malware Solution!

The  wicar.org  website was designed to test the correct operation your anti-virus / anti-malware software. The name " WICAR " is derived from the industry standard  EICAR anti-virus test file ,...

www.wicar.org

 

'IT > 해킹(Hacking)' 카테고리의 다른 글

새로 출시한 모의 해킹 OS  (0) 2023.01.09
hashcat 사용법  (0) 2022.10.20
포맷스트링 공격(Format String Attack)  (0) 2022.01.18
Cross Site Scripting(XSS)이란?  (0) 2022.01.05
Cross-Site Request Forgery(CSRF)이란?  (0) 2022.01.05
728x90

원문출처 : https://solo5star.tistory.com/4

 

우분투 20.04 사용중인 53번 포트 끄기

pi-hole을 설치하려고 했으나 53번 포트가 사용중이라고 뜬다. $ sudo netstat -nap | grep LISTEN tcp 0 0 127.0.0.53:53 0.0.0.0:* LISTEN 633/systemd-resolve tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN 819/sshd: /usr/sbin tcp 0 0 0.0.0.0:445 0.0.0.0

solo5star.tistory.com

pi-hole을 설치하려고 했으나 53번 포트가 사용중이라고 뜬다.

$ sudo netstat -nap | grep LISTEN
tcp        0      0 127.0.0.53:53           0.0.0.0:*               LISTEN      633/systemd-resolve 
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      819/sshd: /usr/sbin 
tcp        0      0 0.0.0.0:445             0.0.0.0:*               LISTEN      835/smbd            
tcp        0      0 0.0.0.0:139             0.0.0.0:*               LISTEN      835/smbd            
tcp        0      0 0.0.0.0:80              0.0.0.0:*               LISTEN      1409/nginx: master  
tcp6       0      0 :::51413                :::*                    LISTEN      1233/docker-proxy   
tcp6       0      0 :::22                   :::*                    LISTEN      819/sshd: /usr/sbin 
tcp6       0      0 :::445                  :::*                    LISTEN      835/smbd            
tcp6       0      0 :::8000                 :::*                    LISTEN      1193/docker-proxy   
tcp6       0      0 :::9091                 :::*                    LISTEN      1278/docker-proxy   
tcp6       0      0 :::9098                 :::*                    LISTEN      1365/grafana-server 
tcp6       0      0 :::9099                 :::*                    LISTEN      1397/prometheus     
tcp6       0      0 :::139                  :::*                    LISTEN      835/smbd            
tcp6       0      0 :::9100                 :::*                    LISTEN      1368/node_exporter  
tcp6       0      0 :::9101                 :::*                    LISTEN      1194/docker-proxy 

sudo를 붙이면 특정 포트를 어떤 서비스에서 쓰는지 확인할 수 있다

 

53번 포트를 쓰는 서비스를 설치한 적이 없는데... 왜 그런가 알아보니 systemd-resolved 서비스에서 DNSStubListener가 53포트를 쓴다고 한다.

 

53번엔 다른 DNS 서비스를 설치할 것이기 때문에, 끌려고 한다.

 

먼저 systemd-resolved 서비스를 멈춘다.

$ sudo systemctl stop systemd-resolved
$ sudo vi /etc/systemd/resolved.conf

 

DNS 서버는 8.8.8.8로, DNSStubListener는 no로 설정하여 꺼준다.

[Resolve]
DNS=8.8.8.8
#FallbackDNS=
#Domains=
#LLMNR=no
#MulticastDNS=no
#DNSSEC=no
#DNSOverTLS=no
#Cache=yes
DNSStubListener=no
#ReadEtcHosts=yes

 

링크를 만들어준다.

$ sudo ln -sf /run/systemd/resolve/resolv.conf /etc/resolv.conf

 

이렇게 하면 53번 포트를 정상적으로 사용할 수 있다.

 

그런데 sudo로 명령어를 치면 아래와 같이 에러 메세지가 뜨는데...

$ sudo
sudo: unable to resolve host Home-NAS: Name or service not known

 

서버의 hostname을 Home-NAS로 설정해두었다.

 

기존엔 우분투에서 Home-NAS를 알아서 localhost로 인식해주었지만 지금은 DNSStubListener를 거치지 않고 바로 8.8.8.8에 질의하기 때문에 이러한 문제가 생긴 것 같다.

 

관련 문제를 검색해보니... /etc/hostname 과 /etc/hosts에 적혀있는 hostname이 달라서 발생한다고 한다.

# /etc/hostname
Home-NAS
# /etc/hosts
127.0.0.1 localhost
127.0.1.1 Home-NAS

 

이렇게 수정해주니 오류가 뜨지 않는다.

 

$ sudo netstat -nap | grep LISTEN
tcp        0      0 0.0.0.0:139             0.0.0.0:*               LISTEN      798/smbd            
tcp        0      0 0.0.0.0:80              0.0.0.0:*               LISTEN      1381/nginx: master  
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      782/sshd: /usr/sbin 
tcp        0      0 0.0.0.0:445             0.0.0.0:*               LISTEN      798/smbd            
tcp6       0      0 :::8000                 :::*                    LISTEN      1174/docker-proxy   
tcp6       0      0 :::9091                 :::*                    LISTEN      1247/docker-proxy   
tcp6       0      0 :::9098                 :::*                    LISTEN      1380/grafana-server 
tcp6       0      0 :::9099                 :::*                    LISTEN      1360/prometheus     
tcp6       0      0 :::139                  :::*                    LISTEN      798/smbd            
tcp6       0      0 :::9100                 :::*                    LISTEN      1372/node_exporter  
tcp6       0      0 :::9101                 :::*                    LISTEN      1194/docker-proxy   
tcp6       0      0 :::51413                :::*                    LISTEN      1196/docker-proxy   
tcp6       0      0 :::22                   :::*                    LISTEN      782/sshd: /usr/sbin 
tcp6       0      0 :::445                  :::*                    LISTEN      798/smbd            

 

드디어 53번 포트를 쓸 수 있게 되었다.

728x90
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa]
"restrictanonymous"=dword:00000001

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters]
"AutoShareServer"=dword:00000000
"AutoShareWks"=dword:00000000

기본공유제거_레지스트리.reg
0.00MB

 

공유폴더 해제

공유폴더는 하드 드라이브가 있는 만큼 자동 생성된다.

C, D 드라이브가 있다면, C$, D$ 자동 생성된다.

ADMIN$, IPC$. PRINT$ 공유폴더도 기본 생성된다

 

  1. [시작] - [제어판] - [관리도구] - [컴퓨터 관리] (또는 실행창에서 compmgmt.msc)
  2. [시스템도구] - [공유 폴더] - [공유] 메뉴를 선택.
  3. 기본 공유 폴더를 오른쪽 클릭해서 [공유 중지] 클릭하면 정지
  4. 또는 커맨드창에서 공유 중지를 할수도 있다.

실행창에서 cmd 입력

C:> net share D$ /delete   ---> D$ 공유폴더 명임.

하지만, 시스템 재부팅 되면 디폴트 값으로 돌아오므로, 레지스트리를 수정한다.

실행창에서 regedit 입력

HKEY_LOCAL_MACHINE  \ SYSTEM  \  CurrentControlSet  \  Services  \  lanmanserver  \  parameters 에서

AutoShareServer 항목의 값을 0으로 설정. (없다면, 새롭게 생성한다. DWORD 32비트 새로만들기.)

Xp에서는 AutoshareWks .

 

cmd 창에서 서비스를 중단-시작 시키면 간단하게 수정된 내용을 확인할  있다.

실행창에서 cmd 입력

C:> net stop server

C:> net start server

C:> net share

 

외부에서 내컴퓨터의 공유폴더로 접근을 차단하기.

실행창에서 regedit 입력

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa 에서

restrictanonymous 값을 1 변경

 

추가사항:

Cd-rom  하드드라이브간에 드라이브명을 변경하게 되면,

Cd-rom  대한 기본 공유폴더가 생성된다.

레지스트리에 정보값이 남게 되어,

 방법 외에 아래 작업을 추가 진행해야 삭제가 된다.

 

레지스트리에 남은 기본공유폴더  삭제하기.

실행창에서 regedit 입력

HKEY_LOCAL_MACHINE  \  SYSTEM  \  CurrentControlSet  \  Services  \  lanmanserver  \  shares 

생성되어 있는 E$(cd-rom 드라이브명) 등의 레지스트리를 삭제한다.

참고사이트: http://blog.naver.com/itexpert2007/30074373559

 

번외: 스크립트를 이용한 net share 설정 (시작프로그램에 등록해서 사용)

배치파일 작성 "net_temp.bat"

 

@echo off
echo net share delete script C$ D$ ADMIN$


echo ====================================

net share /delete C$

net share /delete D$

net share /delete ADMIN$

echo ====================================

 

 

시작>모든 프로그램>시작프로그램> 바로가기를 만들어 집어 넣는다.

 

Windows 재시작 할때 적용 확인

 

C:\>net share

 

공유정보 확인...

 

 

 

728x90

시놀로지1G업로드오류해결.reg
0.00MB

첨부파일 다운로드 후 레지스트리 추가하세요.

 

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WebClient\Parameters]
"FileSizeLimitInBytes"=dword:fa000000
728x90

728x90

원문출처 : https://uniconmaster.tistory.com/3

 

"restart" 실행중인 프로램이 종료되면 감지하여 다시 실행하고 다시 실행된 시점을 로그로 남기는

* .NET Framework 4.0 이상이 설치되어 있어야 실행할 수 있습니다. * 사용방법 * 1. '+' 버튼을 누르면 파일을 열수 있는 창이 나옵니다. 종료되면 자동으로 실행되게 하고싶은 프로그램 실행파일을 선

uniconmaster.tistory.com

 

restart.exe
1.94MB

.NET Framework 4.0 이상이 설치되어 있어야 실행할 수 있습니다.

 

* 사용방법 *

 

1. '+' 버튼을 누르면 파일을 열수 있는 창이 나옵니다.

종료되면 자동으로 실행되게 하고싶은 프로그램 실행파일을 선택합니다.

( exe 파일 또는 exe파일을 가리키고 있는 단축 아이콘만 선택이 가능합니다. )

 

 

 

 

 

 

2. 'ON' 버튼을 클릭하면 정해진시간( 기본 설정 5초 )마다 리스트에 추가된 프로그램이 종료되었는지 확인하고 종료되어 있으면 리스트에 추가된 프로그램들을 다시 실행합니다.

 

아래와 같이 설정되어 있으면 5초마다 EXCEL이 종료되어 있는지 감지합니다.

 

 

* "restart" 프로그램이 종료되고 컴퓨터가 부팅돼도 추가된 프로세스를 OFF상태로 변경하지 않으면 계속해서 실시간으로 감지하므로 감지할 필요가 없는 경우에는 OFF로 변경하셔야 더 이상 감지하지 않습니다.

 

 

 

3. 감시시간 설정은 '시, 분, 초' 단위로 변경이 가능합니다.

 

 

 

 

 

4. '▲' 버튼을 클릭하면 감지 시간이 늘어나고 '▼' 버튼을 클릭하면 감지 시간이 줄어듭니다. 원하는 감지 시간을 설정한 후 '적용' 버튼을 누르면 설정한 감지 시간이 적용됩니다.

 

* 오른쪽 체크박스 *

- 체크박스가 체크되어있지 않으면 '▲' 버튼 또는 '▼' 버튼을 누를때 마다 1씩 증가 또는 감소합니다.

- 체크박스가 체크되어 있으면 '▲' 버튼 또는 '▼' 버튼을 누를때 마다 10씩 증가 또는 감소합니다.

 

* 감지시간은 99:99:99까지 설정 가능합니다.

* 감지시간 변경은 'OFF' 상태에서만 가능합니다.

 

 

 

 

 

5. 리스트에서 원하는 프로그램을 선택하고 '-' 버튼을 누르면 선택된 프로그램이 리스트에서 제거됩니다.

 

 

* 리스트에 추가된 프로그램을 리스트에서 제거하는 기능은 'OFF' 상태에서만 가능합니다.

 

 

 

 

6. 프로그램이 종료되어 다시 실행되는 순간을 시간, 프로그램명 그리고 경로가 다음과 같이 로그파일로 생성됩니다.

 

 

 

 

 

7. 로그파일 경로는 다음과 같습니다. 

 

%localappdata%\restart\log

 

"내 PC"에서 위 경로를 입력하고 Enter키를 누르시면 확인 가능합니다. 

 

 

 

 

 

 

 

서버 운영 시 원인을 알 수 없는 이유로 실행 중인 프로세스가 종료되는 일이 발생하여 언제 프로그램이 종료되었는지 로그로 남겨 종료된 시점을 파악하기 위해서 만든 프로그램입니다.

 

프로그램 사용으로 인해 생긴 문제의 책임은 사용자 본인에게 있습니다.

728x90

원문 출처 : https://computingforgeeks.com/upgrade-to-rocky-linux-9-from-rocky-linux-8/

 

How To Upgrade to Rocky Linux 9 from Rocky Linux 8 | ComputingForGeeks

The most amazing thing is that Rocky Linux is free and open-source, 100% bug-for-bug Red Hat Enterprise Linux compatible distribution. The latest release

computingforgeeks.com

 

Rocky Project는 CentOS의 창시자인 Gregory Kurtzer 에 의해 시작되었습니다. 이것은 Redhat에서 CentOS Linux의 죽음을 발표한 후였습니다. CentOS의 원래 목표를 달성하기 위해 개발된 이 Linux 배포판은 2021년 4월 30일에 처음 출시되었으며 2021년 6월 21일에 일반 출시 버전이 출시되었습니다.

가장 놀라운 점은 Rocky Linux가 무료이며 오픈 소스이며 100% 버그 대 버그 Red Hat Enterprise Linux 호환 배포판이라는 것입니다. 이 Linux 배포판의 최신 릴리스 버전은 Rocky Linux 9 입니다. RHEL 9와 일치하는 이 릴리스 버전은 2022년 7월 14일에 공개되었습니다. 다음과 같은 몇 가지 놀라운 기능과 개선 사항이 포함되어 있습니다.

  • 시스템 모니터링 : CPU, 메모리, 디스크 및 네트워크 사용을 식별하는 데 도움이 되는 메트릭이 있는 업데이트된 Cockpit 웹 콘솔이 있습니다.
  • 프로그래밍을 위한 다음의 새 버전:
    • Rocky Linux 9의 전체 수명 주기 동안 지원될 Python 3.9 
    •  V8 엔진을 버전 9.2로 업그레이드, 새로운 Timer Promises API, 새로운 웹 스트림 API 및 npm 패키지 관리자 버전 7.20.3에 대한 지원을 포함하는 Node.js 16 .
    • Ruby 3.0.3  은 버그 및 보안 수정과 함께 몇 가지 성능 개선 사항을 제공합니다.
    • 유니코드 버전 13을 포함하여 버그 수정 및 개선 사항이 포함된 Perl 5.32  .
    • 구조화된 메타데이터 구문 사용, 순서 독립적인 새로 명명된 인수, Just-In-Time 컴파일 성능 개선 등 버그 수정 및 개선 사항이 포함된 PHP 8.0  .
  • 제공되는 데이터베이스 서버는 다음과 같습니다.
    • 마리아DB 10.5
    • PostgreSQL 13
    • 레디스 6.2
    • MySQL 8.0
  • 파일 시스템 : Rocky Linux 9에서 XFS는 바이트 주소 지정이 가능한 영구 메모리에 대한 직접 액세스를 허용하는 DAX(직접 액세스)를 지원합니다. 이는 기존 블록 I/O 규칙에서 발생하는 대기 시간을 줄이는 데 도움이 됩니다.
  • 새 데스크탑 : Rocky Linux 9 는 기본 데스크탑 환경으로 GNOME 40 을 제공합니다. 핵심 응용 프로그램과 UI를 재설계하여 간단하고 사용하기 쉽게 했습니다. 새로운 모양과 느낌은 작업하고, 앱을 실행하고, 작업 공간을 정렬할 때 완전히 다른 경험을 제공합니다.
  • 다음 컴파일러 및 개발 도구가 추가되었습니다.
    • GCC 11.2.1
    • binutils 2.35.2
    • glibc 2.34
    • Go 도구 세트 1.17.7, LLVM 도구 세트 13.0.1, Rust 도구 세트 1.58.1 등을 포함하는 컴파일러 도구 세트

이 가이드의 주요 목표는 Rocky Linux 8에서 Rocky Linux 9로 업그레이드하는 방법을 보여주는 것입니다.

업그레이드 요구 사항

Rocky Linux 9는 다음 아키텍처에서 지원됩니다.

  • AMD 및 Intel 64비트 아키텍처(x86-64-v2)
  • 64비트 ARM 아키텍처(ARMv8.0-A)
  • IBM Power Systems, Little Endian(POWER9)
  • 64비트 IBM Z(z14)

이 가이드에는 다음이 필요합니다.

  • 작동하는 Rocky Linux 8 시스템.
  • 인터넷 연결
  • 부팅 파티션에 약 100MB의 여유 공간

부인 성명:이것은 프로덕션 Rocky Linux 8 서버를 Rocky Linux 9로 마이그레이션하기 위해 공식적으로 지원되는 방법이 아닙니다.. 수행 중인 작업이 확실하지 않은 경우 프로덕션 서버에서 공유되는 명령을 실행하지 마십시오. 새 OS 설치 및 애플리케이션 마이그레이션에 대한 설치 가이드를 참조하십시오.

1. Rocky Linux 8 서버 준비

시스템과 사용 가능한 모든 패키지를 사용 가능한 최신 버전으로 업데이트하여 시작하십시오.

sudo dnf update -y

시스템에서 사용 가능한 현재 OS 및 버전을 확인합니다.

$ cat /etc/os-release
NAME="Rocky Linux"
VERSION="8.6 (Green Obsidian)"
ID="rocky"
ID_LIKE="rhel centos fedora"
VERSION_ID="8.6"
PLATFORM_ID="platform:el8"
PRETTY_NAME="Rocky Linux 8.6 (Green Obsidian)"
ANSI_COLOR="0;32"
CPE_NAME="cpe:/o:rocky:rocky:8:GA"
HOME_URL="https://rockylinux.org/"
BUG_REPORT_URL="https://bugs.rockylinux.org/"
ROCKY_SUPPORT_PRODUCT="Rocky Linux"
ROCKY_SUPPORT_PRODUCT_VERSION="8"
REDHAT_SUPPORT_PRODUCT="Rocky Linux"
REDHAT_SUPPORT_PRODUCT_VERSION="8"

중요한 시스템 구성을 백업해야 할 수도 있습니다. 이를 위해 사용할 수 있는 몇 가지 도구가 있습니다. 여기에는 다음이 포함됩니다.

  • Rsync –  개인  및  $ 홈  디렉토리 데이터 를 백업하는 데 사용되는 명령줄 유틸리티 도구
  • Deja Dup – 개인 데이터를 백업하는 데 사용되는 GUI 유틸리티입니다.
  • Timeshift – 시스템 파일 및 구성을 백업하는 데 사용되는 도구입니다.
  • Restic – 다른 백엔드에 저장된 암호화된 리포지토리에 파일의 여러 개정판을 저장하는 명령줄 유틸리티 도구입니다.
  • Rsnapshot – 이것은 ssh를 통해 로컬 및 원격 시스템에 대한 주기적 스냅샷을 생성하는 명령줄 유틸리티 도구입니다.
  • Bacula – 네트워크를 통한 데이터 백업, 복원 및 검증을 관리하는 데 사용되는 프로그램 세트. Rocky Linux 8|AlmaLinux 8에서 Bacula Backup 을 설치하고 사용하는 방법에 대한 자세한 정보는 가이드에 캡처되어 있습니다.

시스템 백업이 완료되면 그림과 같이 진행하십시오.

2. Rocky Linux 9 저장소 추가

Rocky Linux 9 저장소를 추가하고 시스템에 키 서명을 추가하여 시작하십시오. 공식 repo 웹 경로 에서 최신 패키지 릴리스를 참조하십시오 .

REPO_URL="https://download.rockylinux.org/pub/rocky/9/BaseOS/x86_64/os/Packages/r"
RELEASE_PKG="rocky-release-9.0-2.2.el9.noarch.rpm "
REPOS_PKG="rocky-repos-9.0-2.2.el9.noarch.rpm "
GPG_KEYS_PKG="rocky-gpg-keys-9.0-2.2.el9.noarch.rpm"

이에 사용되는 명령은 다음과 같습니다.

sudo dnf --nogpgcheck -y install $REPO_URL/$RELEASE_PKG $REPO_URL/$REPOS_PKG $REPO_URL/$GPG_KEYS_PKG 

3. 필요한 Rocky Linux 9 패키지 설치

추가된 저장소를 구성하고 Rocky Linux 9에 필요한 모든 패키지를 설치합니다. 하지만 먼저 root사용자로 전환하고 아래 패키지를 제거합니다.

sudo su - 
dnf -y remove rpmconf yum-utils epel-release

redhat-logos또한 여기에서 필요하지 않은 항목 을 삭제해야 합니다.

rm -rf /usr/share/redhat-logos

이제 Rocky Linux 9에 필요한 모든 패키지를 설치하십시오

dnf -y --releasever=9 --allowerasing --setopt=deltarpm=false distro-sync

이 프로세스는 많은 패키지를 설치/업그레이드해야 하므로 시간이 걸릴 수 있습니다. 완료되면 아래와 같이 진행합니다.

4. Rocky Linux 커널 업데이트

이전 커널을 제거하고 최신 커널이 설치되었는지도 확인해야 합니다. 여기에 사용된 명령은 다음과 같습니다.

rpm  -qa | grep kernel

샘플 출력:

warning: Found bdb_ro Packages database while attempting sqlite backend: using bdb_ro backend.
kernel-core-4.18.0-372.16.1.el8_6.0.1.x86_64
kernel-modules-4.18.0-372.9.1.el8.x86_64
kernel-tools-libs-5.14.0-70.17.1.el9_0.x86_64
kernel-core-5.14.0-70.17.1.el9_0.x86_64
kernel-modules-4.18.0-372.16.1.el8_6.0.1.x86_64
kernel-modules-5.14.0-70.17.1.el9_0.x86_64
kernel-tools-5.14.0-70.17.1.el9_0.x86_64
kernel-5.14.0-70.17.1.el9_0.x86_64
kernel-4.18.0-372.16.1.el8_6.0.1.x86_64
kernel-core-4.18.0-372.9.1.el8.x86_64
kernel-4.18.0-372.9.1.el8.x86_64

위의 출력에서 ​​RPM 저장소를 다시 빌드해야 한다는 경고가 표시됩니다.

cd /var/lib/rpm 
rm -f __db.00*
rpm --rebuilddb

이제 아래 명령을 실행하여 출력에서 ​​이전 커널 4.18.*을 제거하십시오.

rpm -e --nodeps  `rpm -qa|grep -i kernel|grep 4.18`

커널을 확인하기 위해 명령을 다시 실행하면 커널 4.18이 제거되어야 합니다.

$ rpm  -qa | grep kernel
kernel-tools-libs-5.14.0-70.17.1.el9_0.x86_64
kernel-core-5.14.0-70.17.1.el9_0.x86_64
kernel-modules-5.14.0-70.17.1.el9_0.x86_64
kernel-tools-5.14.0-70.17.1.el9_0.x86_64
kernel-5.14.0-70.17.1.el9_0.x86_64

시스템에 5.x 커널 이 없으면 다음 명령을 사용하여 설치합니다.

dnf -y install kernel kernel-core shim

샘플 출력:

Dependencies resolved.
===================================================================================
 Package               Architecture  Version                   Repository     Size
===================================================================================
Installing:
 shim-x64              x86_64        15.4-2.el9.rocky.1        baseos        669 k
Installing dependencies:
 efi-filesystem        noarch        6-2.el9_0                 baseos        7.7 k
 mokutil               x86_64        2:0.4.0-8.el9_0.1         baseos         44 k

Transaction Summary
===================================================================================
Install  3 Packages

Total download size: 721 k

위의 출력 에서 ​​특정 모듈의 오류 가 있으며 활성화된 모듈을 나열합니다.

# dnf module list
........
Name               Stream    Profiles Summary                                      
container-tools    rhel8 [e] common   Most recent (rolling) versions of podman, bui
                                      ldah, skopeo, runc, conmon, runc, conmon, CRI
                                      U, Udica, etc as well as dependencies such as
                                       container-selinux built and tested together,
                                       and updated as frequently as every 12 weeks.
llvm-toolset       rhel8 [e] common   LLVM                                         
perl               5.26 [e]  common,  Practical Extraction and Report Language     
                             minimal                                               
perl-DBD-SQLite    1.58 [e]  common   SQLite DBI driver                            
perl-DBI           1.641 [e] common   A database access API for Perl               
perl-IO-Socket-SSL 2.066 [e] common   Perl library for transparent TLS             
perl-libwww-perl   6.34 [e]  common   A Perl interface to the World-Wide Web       
python36           3.6 [e]   build, c Python programming language, version 3.6     
                             ommon                                                 
virt               rhel [e]  common   Virtualization module                        

Hint: [d]efault, [e]nabled, [x]disabled, [i]nstalled

다음 명령으로 비활성화합니다.

dnf module disable  perl container-tools llvm-toolset  virt perl-IO-Socket-SSL perl-libwww-perl python36 perl-DBI perl-DBD-SQLite

샘플 출력:

Dependencies resolved.
===================================================================================
 Package            Architecture      Version             Repository          Size
===================================================================================
Disabling modules:
 container-tools                                                                  
 llvm-toolset                                                                     
 perl                                                                             
 perl-DBD-SQLite                                                                  
 perl-DBI                                                                         
 perl-IO-Socket-SSL                                                               
 perl-libwww-perl                                                                 
 python36                                                                         
 virt                                                                             

Transaction Summary
===================================================================================

Is this ok [y/N]: y

5. 시스템 업데이트 및 재부팅

이 시점에서 모든 패키지가 최신 상태이므로 시스템에서 업데이트할 내용이 많지 않습니다. 패키지를 업데이트하려면 다음 명령을 실행합니다.

dnf update -y

시스템을 재부팅합니다.

reboot

그림과 같이 시스템이 Rocky Linux 9로 부팅됩니다.

6. Rocky Linux 9 활동 업그레이드 후.

시스템이 재부팅되면 시스템 사용자를 사용하여 로그인합니다.

Rocky Linux 9는 둘러보고 Rocky Linux 9에 익숙해져야 하는 아래 창으로 시작됩니다.

다음과 같이 놀라운 Gnome 40 데스크탑 환경이 시작됩니다.

설치를 확인하려면 설정 -> 정보 로 이동하십시오.

neofecth또는 다음 과 같이 설치하고 사용할 수 있습니다 .

sudo yum install epel-release -y
sudo dnf install neofetch -y

Rocky Linux 버전을 확인하십시오.

이제 다음 명령을 사용하여 시스템을 업데이트할 수 있습니다.

sudo dnf update -y

선호하는 도구를 설치하십시오. 예를 들어 vim텍스트 편집기

sudo dnf install vim

모든 것이 원하는 대로 작동하는지 확인한 후 이전에 만든 백업을 복원할 수 있습니다.

끝!

Rocky Linux 8에서 Rocky Linux 9로 업그레이드하는 방법에 대한 이 가이드가 귀하에게 의미가 있기를 바랍니다. 최고 관리자가 되는 데 도움이 되는 다른 Rocky Linux 가이드를 웹사이트에서 확인하십시오.

728x90

참고 사이트 - https://hub.docker.com/r/linuxserver/snapdrop

 

Docker Hub

 

hub.docker.com

Send-Anywhere 와 같은 기능을 하는 서버

 

---
version: "2.1"
services:
  snapdrop:
    image: lscr.io/linuxserver/snapdrop:latest
    container_name: snapdrop
    environment:
      - PUID=1000
      - PGID=1000
      - TZ=Asia/Seoul
    volumes:
      - ./config:/config
    ports:
      - 80:80
      - 443:443
    restart: always
728x90

개요

이 문서에서는 OPNsense에서 LAN 브리지를 활성화하는 방법을 다룹니다. LAN 브리지는 Vault의 선택적 포트를 사용하여 스위치 역할을 합니다. 별도의 물리적 스위치를 사용하는 것에 비해 최적은 아니지만 필요한 경우 작동합니다.

참고: 웹 인터페이스에 액세스하는 데 사용되는 포트가 브리지에 추가된 경우 볼트에 대한 물리적 액세스가 필요합니다.

OPNsense에서 LAN 브리지를 만드는 방법

이 예에서는 Vaults 추가 포트 OPT1  OPT2 를 포함하는 브리지 에 LAN 인터페이스를 할당합니다 . 이 예의 아이디어는 약간의 변형으로 모든 Vault 모델에서 사용할 수 있습니다.

  • 웹 인터페이스에 액세스합니다. 기본 IP 주소: 192.168.1.1 , 사용자 이름: root , 암호: opnsense
  • 볼트 옵션 인터페이스( OPT1 , OPT2 등)가 기본 설정으로 할당되었는지 확인합니다. ' + '를 클릭한 다음 저장 을 클릭하여 할당할 수 있습니다.

OPNsense 인터페이스 할당 메뉴(FW4A)

  • 인터페이스 트리에서 OPT1 메뉴 를 엽니다.
  • 인터페이스 활성화 를 확인 하십시오 . 모든 설정을 기본값으로 두십시오.
  • 저장 을 클릭 한 다음 적용 을 클릭 하면 상단이 변경됩니다.
  • 브리지에 포함될 추가 인터페이스에서 반복

OPNsense 인터페이스 메뉴

  • 인터페이스 트리에서 기타 유형 을 선택한 다음 브리지 를 선택 합니다.
  • 추가 를 클릭 하고 OPT1, OPT2 등을 선택한 다음 저장 을 클릭합니다.

OPNsense 브리지 메뉴

  • 인터페이스 트리에서 할당 을 선택 합니다.
  • LAN 인터페이스를 bridge0 으로 변경하고 저장 을 클릭 합니다.

참고: 이 시점에서 웹 인터페이스에 대한 액세스가 손실됩니다. 다시 액세스하려면 OPT1 또는 OPT2 포트에 연결하십시오.

OPNsense 할당 메뉴

  • Assignments 메뉴에서 이전에 LAN 에 할당된 포트( em1 )를 추가 합니다 . 저장 클릭
  • 이제 OPT3 이 할당 되었는지 확인
  • 기본 설정으로 OPT3 를 활성화 합니다. 변경 사항 저장 및 적용
  • Bridge 메뉴로 돌아가서 bridge0 을 편집하십시오 . OPT3 추가 및 저장

  • 이제 LAN 포트에 웹 인터페이스 액세스 권한이 있는지 확인하십시오.
  • 시스템 > 설정 > 조정 가능 항목 으로 이동합니다.
  • net.link.bridge.pfil_member 찾아 해당 설정을 Default 에서 0 으로 변경합니다 . 변경 사항 저장 및 적용
  • 이전 설정 바로 아래에 있는 net.link.bridge.pfil_bridge 를 찾아 설정을 Default 에서 1 로 변경합니다 . 변경 사항 저장 및 적용

시스템 튜너블 메뉴

  • 재부팅
  • 브리지된 포트가 작동하는지 확인
728x90

원문출처 : https://blog.dalso.org/article/esxi-6-7-%EC%84%A4%EC%B9%98%EB%90%9C-%EC%83%81%ED%83%9C%EC%97%90%EC%84%9C-%EB%93%9C%EB%9D%BC%EC%9D%B4%EB%B2%84-%EC%B6%94%EA%B0%80%ED%95%98%EA%B8%B0-realtek-8125

 

ESXI 6.7 설치된 상태에서 드라이버 추가하기.(Realtek 8125) - 달소씨의 하루

안녕하세요. 달소입니다. 오랜만에 ESXI 관련글이네요 ㅎㅎ 이번편은 사용하고있는 ESXi에 드라이버를 추가하는방법입니다. 드라이버를 추가하는 이유는 다양하겠지만 새로 pci에 디바이스를 꽂

blog.dalso.org

 

오랜만에 ESXI 관련글이네요 ㅎㅎ

이번편은 사용하고있는 ESXi에 드라이버를 추가하는방법입니다.

드라이버를 추가하는 이유는 다양하겠지만 새로 pci에 디바이스를 꽂았는데 인식이 안된다거나..

뭐 여러가지 경우에 사용할 수 있을거라 생각합니다.

저같은경우 ESXi를 설치한 메인보드의 메인 LAN이 Realtek 8125B 2.5G랜인데 인식을 못해서..

인식시켜보도록하겠습니다.

1. 드라이버다운로드하기

먼저 ESXi에 설치할 드라이버를 다운로드 받아주세요.

저같은경우 Realtek 8125 드라이브를 받았습니다.

net-r8125-9.004.01-2-offline_bundle.zip
0.08MB
Realtek_r8125-NIC-offline_bundle-9.007.01-1-ESXi_6.x.zip
0.09MB

https://github.com/realganfan/r8125-esxi

net-r8125-9.004.01-2-offline_bundle.zip

다운로드 받으시고 ESXi 관리페이지 -> 데이터스토어에 업로드를 시켜주세요.

이제 직접 터미널에 연결해서 명령어를 입력해줘야하기때문에

ESXi의 SSH 터미널을 활성화시키겠습니다.

ESXi SSH 터미널 활성화하기

관리 -> 서비스 -> TSM-SSH -> 시작

계정은 사용하고계신 root 계정을 입력해주시면됩니다.

드라이버 설치하기

이제 업로드한 파일을 찾아서 드라이버를 설치해보겠습니다.

경로는 /vmfs/volumes/[데이터스토어이름]/[드라이버를 업로드한 폴더] 이렇게 되겠습니다.

이 경로의 드라이버를 설치해보겠습니다 명령어는 아래처럼입력해주세요.

esxcli software vib install -d /vmfs/volumes/datastore1/Driver/net-r8125-9.004.01-2-offline_bundle.zip

혹 위 명령어가 안되신다면 맨뒤에 -f 옵션을 붙여주시면됩니다.

위에 보다시피 Reboot Required true기 때문에 재부팅 해야 정상적으로 사용이 가능합니다.

재부팅 전 네트워크 어댑터 현황

재부팅 후 네트워크 어댑터 현황

뭐,, 애초에 이미지에 묶어서 만드는것도 하나해놔야겠네요 ㅎㅎ

728x90

원문출처 : https://myhappyman.tistory.com/226

 

Docker - 방화벽 이슈(서비스를 올리면 외부망 허용 현상)

도커를 통해 서비스를 구성해서 테스트를 하는 도중 테스트서버가 털려버렸다. 0.015 BTC를 내놓으면 어쩌구 저쩌구.. 다행이 다른건 털린건 없지만... (털릴 정보도 없는 빈 서버였다.) 기존에 설

myhappyman.tistory.com

도커를 통해 서비스를 구성해서 테스트를 하는 도중 테스트서버가 털려버렸다.

0.015 BTC를 내놓으면 어쩌구 저쩌구.. 다행이 다른건 털린건 없지만... (털릴 정보도 없는 빈 서버였다.)

 

기존에 설정해둔 방화벽 서비스 ufw가 일단 내려가 있었고, 도커로 엘라스틱 몽고 서비스를 구동해보니 서버에 항상 해당 포트들을 외부에서 접근 할 수 있도록 허용해주고 있었다.

 

찾아보니 도커가 기본적으로 서비스를 구동하면 기존에 UFW가 동작하고 있어도 기본 옵션이 열어주도록 되어 있었다.

 

Docker 방화벽 옵션 끄기

로컬 서비스에서만 도커에서 올린 서비스를 사용하고 싶은 경우가 있다.

이런 경우 옵션을 주면 방화벽에 영향을 주지않고 서비스만 올라오는데 일반적으로 설정하는 방식은 아래와 같다.

 

/etc/docker/damon.json

{
	"iptables": false
}

 

이후 서비스 재기동을 한다.

systemctl restart docker

 

 

하지만, 내가 설치한 서버의 /etc/docker/쪽에는 해당하는 파일도 없었을 뿐더러 파일을 생성하고 재기동하여도 여전히 외부에서 접근이 가능하였다.

다른 글들을 더 찾아보니 도커가 실행되는 서비스 옵션을 변경하라는 글을 찾아서 아래와 같이 적용 후 재기동하니 정상적으로 외부에서 접근이 안되는 모습을 확인하였다.

 

/etc/systemd/system/multi-user.target.wants/docker.service

ExceStart 옵션 제일 마지막에 --iptables=false를 추가한 후 저장합니다.

 

재기동 하기전 아래 명령어를 입력합니다.

systemctl daemon-reload

이후 재기동을 해서 해당 포트가 외부에서 접근이 안되는지 확인합니다.

728x90

원문출처 : https://hiseon.me/security/hashcat-tutorial/

 

hashcat 사용법 - HiSEON

hashcat 사용법 다양한 종류의 패스워드를 복원할 수 있는 hashcat 사용법에 대해서 설명드립니다. hashcat 설치 방법과 옵션, Mask 설정 방법 등 hashcat 명령어 사용법에 대해서 hashcat 예제 함께 설명드

hiseon.me

 

hashcat 사용법
다양한 종류의 패스워드를 복원할 수 있는 hashcat 사용법에 대해서 설명드립니다. hashcat 설치 방법과 옵션, Mask 설정 방법 등 hashcat 명령어 사용법에 대해서 예제와 함께 설명드립니다.

hashcat 소개

Hashcat은 GPU를 기반으로 하여 빠르게 패스워드를 크랙 할 수 있는 툴로 다양한 암호화 알고리즘을 지원하고 있습니다.
CPU 또한 지원하지만 GPU 대비 속도가 느립니다. GPU 를 사용할 경우 빠르게 패스워드를 찾아 낼 수 있으며 여러개의 GPU가 존재할 경우 각각 GPU 별로 나눠서 분산 처리를 할 수 있습니다.

패스워드에 대한 길이와 구성 문자등에 대한 힌트가 있을 경우 세부적으로 규칙을 정의하여 패스워드를 검색해 나갈 수 있습니다.

다양한 옵션이 지원되는 만큼 hashcat 사용법이 조금 어려울 수 있는데, 예제를 통해서 함께 설명 드리도록 하겠습니다.

hashcat 설치

hashcat을 설치하여 사용하기 위해서는 먼저 GPU 드라이버를 설치해 주셔야 합니다. NVIDIA GPU를 사용하고 계신 경우 아래의 글을 참고하여 드라이버를 설치 할 수 있습니다.

우분투에서 NVIDIA 드라이버 설치 방법

드라이버 설치 후 nvidia-smi 명령어를 실행하면 다음과 같이 GPU 목록을 확인 할 수 있습니다.

그 다음 우분투 리눅스 환경일 경우 아래의 명령어를 이용하여 hashcat을 설치 할 수 있습니다.

$ apt install hashcat

패키지가 설치 된 후에 다음은 명령어를 실행하여, 버전이 출력된다면 제대로 설치가 이뤄진 것입니다.

$ hashcat --version

hashcat 옵션

먼저 hashcat에서 지원되는 옵션을 확인하기 위해서는 다음 명령어를 실행하면 됩니다.

$ hashcat --help

해쉬 유형, 검색 모드, 문자 코드 등 주요 옵션에 대해서 설명드리도록 하겠습니다.

해쉬 유형

계산해서 찾아낼 패스워드의 해쉬 유형입니다. -m 옵션을 지정하여 사용할 수 있습니다. 예를 들어 md5 알고리즘의 해쉬값의 패스워드를 복원하기 위해서는 0 값을 지정하면 됩니다.

- [ Hash modes ] -

      # | Name                                             | Category
  ======+==================================================+======================================
    900 | MD4                                              | Raw Hash
      0 | MD5                                              | Raw Hash
   5100 | Half MD5                                         | Raw Hash
    100 | SHA1                                             | Raw Hash
   1300 | SHA-224                                          | Raw Hash
   1400 | SHA-256                                          | Raw Hash
  10800 | SHA-384                                          | Raw Hash
   1700 | SHA-512                                          | Raw Hash

검색 모드

패스워드를 검색하는 방법을 지정하는 옵션으로 -a 옵션명을 사용합니다. 주로 사용되는 옵션 값은 Brute-force으로 3 값을 사용합니다.

- [ Attack Modes ] -

  # | Mode
 ===+======
  0 | Straight
  1 | Combination
  3 | Brute-force
  6 | Hybrid Wordlist + Mask
  7 | Hybrid Mask + Wordlist

패스워드 문자셋

hashcat에서 사용되는 문자셋 입니다. 패스워드를 찾기 위해 시도할 문자를 정의할 때 사용됩니다.

- [ Built-in Charsets ] -

  ? | Charset
 ===+=========
  l | abcdefghijklmnopqrstuvwxyz
  u | ABCDEFGHIJKLMNOPQRSTUVWXYZ
  d | 0123456789
  h | 0123456789abcdef
  H | 0123456789ABCDEF
  s |  !"#$%&'()*+,-./:;<=>?@[\]^_`{|}~
  a | ?l?u?d?s
  b | 0x00 - 0xff

hashcat 사용법

hashcat을 이용하여 어떻게 패스워드를 찾아 낼 수 있는지 예제를 통해서 설명드리도록 하겠습니다. 다음과 같이 hello 문자열의 md5를 계산하여, 계산된 md5로부터 문자열을 찾아내 보도록 하겠습니다.

$ echo -n "hello" | md5sum

위에서 확인된 hash 값을 다음과 같이 파일로 저장합니다.

$ echo "5d41402abc4b2a76b9719d911017c592" > example.hash

그리고 다음 명령어로 hashcat을 실행합니다. hashcat 명령어를 실행하는데 사용되는 옵션은 다음과 같습니다.

  • -a 3 : 패스워드 검색 방밥으로 Brute-force 모드(3) 를 사용합니다.
  • -m 0 : 해쉬 알고리즘으로 MD5을 사용합니다.
  • example.hash : 해쉬 파일이 저장된 경로 입니다.
  • ?a x 6 : 하나의 ?a 는 (?l?u?d?s) 으로 소문자, 대문자, 숫자, 특수기호 의 하나의 문자를 의미하며 ?a 여섯개 있으므로 6자리의 이 문자들을 검색합니다.
$ hashcat -a 3 -m 0 example.hash ?a?a?a?a?a

위의 명령어를 실행한 결과는 아래와 같습니다. 실행 중간에 아래와 같이 md5 값으로 부터 원래의 문자열을 찾은 것을 확인 할 수 있습니다.

5d41402abc4b2a76b9719d911017c592:hello

찾아낸 패스워드는 해쉬 값과 같이 ~/.hashcat/hashcat.potfile 위치에 저장되게 됩니다. 동일한 해쉬값을 검색할 경우는 다시 연산을 통해서 패스워드를 찾아내지 않고 potfile에 저장된 내용을 출력합니다.

728x90

원문출처 : https://ja-gamma.tistory.com/entry/%EC%9C%A0%EB%B9%84%EC%BF%BC%EC%8A%A4-%EC%8A%A4%EC%9C%84%EC%B9%98-Config-%EB%AA%85%EB%A0%B9%EC%96%B4-%EB%AA%A8%EC%9D%8C

 

유비쿼스 스위치 - Config 명령어 모음

최근 국내 저가 스위치로 많이 사용하던 다산 스위치가 하락하면서 동급 국내 벤더인 유비쿼스 스위치의 사용률이 높아지고 있습니다. 그래서 이번 시간에는 유비쿼스 스위치의 기본 Config 명령

ja-gamma.tistory.com

 

최근 국내 저가 스위치로 많이 사용하던 다산 스위치가 하락하면서 동급 국내 벤더인 유비쿼스 스위치의 사용률이 높아지고 있습니다. 그래서 이번 시간에는 유비쿼스 스위치의 기본 Config 명령어와 장비들에 대해서 간단히 알아보도록 하겠습니다.

 

 

1. 유비쿼스 스위치 기본

 

: 유비쿼스를 처음하시는 분들도 많겠지만 , 편하게 시스코 스위치랑 비슷하다?라고 생각하시면 됩니다. 콘솔 접속도 9600이고 명령어도 비슷한 부분이 많기 때문에 시스코를 다뤄보신 분들은 크게 어려움이 없을거라고 생각됩니다.

 

유비쿼스 스위치는 최초 접속 시 " login : admin " , Password : frontier " 패스워드 생성 규칙은 '9자 이상 16자 이하의 길이 , 영문 대문자/소문자 , 특수문자 , 숫자 중 3가지 조합이상'의 조건을 만족하시면 됩니다.

 

 

 

 

 

 

 

 

2. 유비쿼스 스위치 기본 명령어

 

- Hostname 설정

Switch# conf t

Switch(config)# hostname XXXXX (한글 , 영문 , 기호 설정 가능 , 최대 63자)

Switch(config)# no hostname

 

 

- 로그인 계정 설정

Switch(config)# username admin privilege 15 password

New password : admin123

retype new password : admin123

Switch(config)# enable password

New password : admin123

retype new password : admin123

 

 

- VLAN 생성

Switch(config)# vlan database

Switch(config-vlan)# vlan 10

Switch(config-vlan)# vlan 20

Switch# show vlan

 

 

- VLAN 적용 (access)

Switch(config)# interface gi0/1

Switch(config-if-giga0/1)# switchport mode access

Switch(config-if-giga0/1)# switchport access vlan 10

 

 

- VLAN 적용 (trunk)

Switch(config)# interface gi0/1

Switch(config-if-giga0/1)# switchport mode trunk

Switch(config-if-giga0/1)# switchport trunk allowed vlan add 10

Switch(config-if-giga0/1)# switchport trunk allowed vlan add 20

 

 

- IP Address 설정

Switch(config)# interface vlan10

Switch(config-if-vlan10)# ip address 10.1.1.1/24

Switch(config-if-vlan10)# ip address 10.2.1.1/24 secondary

 

 

- 라우팅 테이블 설정

Switch(config)# ip route 0.0.0.0/0 10.1.1.254

 

 

- 배너 설정

Switch(config)# banner login ^C

!!!!!!!!!!!!!! WARNING !!!!!!!!!

배너 내용

 

 

- SNMP 설정

Switch(config)# snmp-server community ro

New password : public

retype new password : public

Switch(config)# snmp-server enable traps

Switch(config)# snmp-server host 1.1.1.1 version 2c

 

 

 

 

 

3. 유비쿼스 명령어 모음 2 (상위 명령어)

 

- session logout 설정

Switch(config)# line vty 0 7

Switch(config-line)# exec-timeout 5 0

Switch(config)# line console 0

Switch(config-line)# exec-timeout 5 0

 

 

- 허용된 IP만 접속되는 ACL 설정

Switch(config)# access-list 23 permit 1.1.1.1 0.0.0.0

Switch(config)# access-list 23 deny any

Switch(config)# ip option telnet-acl access-group 23

 

 

- ACL 설정

Switch(config)# access-list 102 deny tcpany anyeq445

Switch(config)# access-list 102 deny udpany anyeq3702

Switch(config)# access-list 102 deny ip10.4.11.246 0.0.0.0 any

Switch(config)# interface range GigabitEthernet1/1/1-1/1/12

Switch(config-if-range)# ipaccess-group 102 in

 

 

- STP 설정

Switch(config)# spanning-tree mode stp

Switch(config)# spanning-tree priority 4096

Switch(config)# spanning-tree enable

Switch(config)# interface range gi0/1-0/24

Switch(config-if-range)# spanning-tree portfast

Switch(config)# interface gi0/25

Switch(config-if-Giga0/25)# spanning-tree path-cost 20000

 

→ RSTP 설정시

Switch(config)# spanning-tree mode rstp

Switch(config)# spanning-tree priority 4096

Switch(config)# spanning-tree enable

Switch(config)# interface range gi0/1-0/24

Switch(config-if-range)# spanning-tree portfast

Switch(config)# interface gi0/25

Switch(config-if-Giga0/25)# spanning-tree path-cost 20000

 

 

- VRRP 설정 (이중화)

→ MASTER설정

Switch(config)# router vrrp10 vlan10

Switch(config-router)# virtual-ip10.1.1.254 backup

Switch(config-router)# circuit-failover gi0/25 60

Switch(config-router)# priority 105

Switch(config-router)# preempt-mode true

Switch(config-router)# enable

 

→ BACKUP설정

Switch(config)# router vrrp10 vlan10

Switch(config-router)# virtual-ip10.1.1.254 backup

Switch(config-router)# enable

 

 

- Voice VLAN 설정

Switch(config)# interface gi0/1

Switch(config-if-Giga0/1)# switchportaccess vlan100

Switch(config-if-Giga0/1)# switchportvoice vlan200

Switch(config-if-Giga0/1)# mlsqostrust dscp

 

 

- DHCP 설정

→ dhcprelay 모드설정

Switch(config)# service dhcprelay

Switch(config)# ipdhcp-server 20.1.1.1

 

→ dhcpserver 모드설정

Switch(config)# service dhcp

Switch(config)# ipdhcppool TEST

Switch(dhcp-config)# network 10.1.1.0/24

Switch(dhcp-config)# default-router 10.1.1.1

Switch(dhcp-config)# range 10.1.1.2 10.1.1.100

Switch(dhcp-config)# dns-server 168.126.63.1

Switch(dhcp-config)# lease 0 0 60

Switch(dhcp-config)# domain-name Ubiquoss

 

 

- 서비스 활성화

Switch(config)# service ssh

Switch(config)#ipsshport 5000

Switch(config)# no service telnet

728x90

원문출처 : https://sonhc.tistory.com/958

 

[docker] code server 설치 (docker-compose 방식)

웹에서 VS code를 사용할 수 있는 code server 서비스를 도커 컴포즈로 설치하는 가이드입니다. 1. docker-compose 방법 1-1) 기본 디렉토리 생성 sudo mkdir -p <컨테이너_실행_경로> e.g. /volume..

sonhc.tistory.com

웹에서 VS code를 사용할 수 있는 code server 서비스를 도커 컴포즈로 설치하는 가이드입니다.

 

 

1. docker-compose 방법

1-1) 기본 디렉토리 생성

  • sudo mkdir -p <컨테이너_실행_경로>
    e.g. /volume1/docker/code_server
  • sudo mkdir -p <데이터_볼륨_경로>
    e.g. /volume1/docker/code_server/volume/config

 

1-2) docker-compose.yml 작성

  • sudo vim <도커_컴포즈_파일_경로>   
    e.g. /volume1/docker/code_server/docker-compose.yml
docker-compose.yml
version: "3.1"
services:
  code-server:
    image: lscr.io/linuxserver/code-server:latest
    container_name: code-server
    restart: always
    ports:
      - "50011:8443"
    environment:
      - PUID=1000
      - PGID=1000
      - TZ=Asia/Seoul
      - PASSWORD=12345678
      - SUDO_PASSWORD=12345678
      - DEFAULT_WORKSPACE=/config/workspace
    volumes:
      - ./volume/config:/config
      - ./volume/source:/config/workspace
설명
    container_name: <컨테이너_이름>
    restart: <재시작_옵션>
      - "<접속_포트>:8443"
      - PUID=<UID>
      - PGID=<GID>
      - TZ=<지역/도시>
      - PASSWORD=<암호>
      - SUDO_PASSWORD=<암호>
      - <컨테이너_볼륨_config_경로>:/config
      - <컨테이너_볼륨_source_경로>:/config/workspace

 

1-3) docker-compose 설치

  • sudo docker-compose up -d

 

1-4) 접속 확인

  • http://<HOST_IP>:<접속_포트>
    e.g. http://192.168.10.10:50011

 

 

참조 : https://hub.docker.com/r/linuxserver/code-server

 

Docker Hub

 

hub.docker.com

---
version: "2.1"
services:
  code-server:
    image: lscr.io/linuxserver/code-server:latest
    container_name: code-server
    environment:
      - PUID=1000
      - PGID=1000
      - TZ=Asia/Seoul
      - PASSWORD=password #optional
      - HASHED_PASSWORD= #optional
      - SUDO_PASSWORD=password #optional
      - SUDO_PASSWORD_HASH= #optional
      - PROXY_DOMAIN=code-server.my.domain #optional
      - DEFAULT_WORKSPACE=/config/workspace #optional
    volumes:
      - /path/to/appdata/config:/config
    ports:
      - 8443:8443
    restart: always
 
728x90

참고 사이트 - https://hub.docker.com/r/linuxserver/mstream

 

Docker Hub

 

hub.docker.com

아래 코드로 docker-compose.yml 파일 생성 후 'docker-compose up -d'로 실행하세요.

 

---
version: "2.1"
services:
  mstream:
    image: lscr.io/linuxserver/mstream:latest
    container_name: mstream
    environment:
      - PUID=1000
      - PGID=1000
      - TZ=Asia/Seoul
    volumes:
      - ./config:/config
      - ./music:/music
    ports:
      - 3000:3000
    restart: always
728x90

참고 사이트 - https://www.seafile.com/en/home/

 

Seafile - Open Source File Sync and Share Software

 

www.seafile.com

version: '2.0'
services:
  db:
    image: mariadb:10.5
    container_name: seafile-mysql
    environment:
      - MYSQL_ROOT_PASSWORD=db_dev  # Requested, set the root's password of MySQL service.
      - MYSQL_LOG_CONSOLE=true
    volumes:
      - /opt/seafile-mysql/db:/var/lib/mysql  # Requested, specifies the path to MySQL data persistent store.
    networks:
      - seafile-net

  memcached:
    image: memcached:1.6
    container_name: seafile-memcached
    entrypoint: memcached -m 1024
    networks:
      - seafile-net
          
  seafile:
    image: seafileltd/seafile-mc:latest
    container_name: seafile
    ports:
      - "80:80"
#     - "443:443"  # If https is enabled, cancel the comment.
    volumes:
      - ./seafile-data:/shared   # Requested, specifies the path to Seafile data persistent store.
    environment:
      - DB_HOST=db
      - DB_ROOT_PASSWD=db_dev  # Requested, the value shuold be root's password of MySQL service.
      - TIME_ZONE=Asia/Seoul  # Optional, default is UTC. Should be uncomment and set to your local time zone.
      - SEAFILE_ADMIN_EMAIL=me@example.com # Specifies Seafile admin user, default is 'me@example.com'.
      - SEAFILE_ADMIN_PASSWORD=asecret     # Specifies Seafile admin password, default is 'asecret'.
      - SEAFILE_SERVER_LETSENCRYPT=false   # Whether to use https or not.
      - SEAFILE_SERVER_HOSTNAME=docs.seafile.com # Specifies your host name if https is enabled.
    depends_on:
      - db
      - memcached
    networks:
      - seafile-net

networks:
  seafile-net:

 

Seafile 파일 업로드 실패 - 네트워크 오류

이것으로 문제가 해결되었습니다: Seafile 웹 UI에 로그인하고 아바타를 클릭한 후 "System Admin" > Settings > FILE_SERVER_ROOT > 그리고 여기에 다음과 같이 Seafile URL 또는 IP 주소를 입력해야 합니다.
"hxxp://{YOUR_SERVER_URL}/seafhttp"
예를 들어, 내 서버 URL은 "seafile.local"이기 때문에 다음과 같이 입력합니다.
hxxp://seafile.local/seafhttp

docker-syslog.yml 파일의 'SEAFILE_SERVER_HOSTNAME='에 저장할 수도 있습니다.
URL이 (seafile.local)과 같은 도메인 이름인 경우 DNS 서버에 해당 URL에 대한 기록이 있어야 합니다.
저는 Pi-Hole을 제 로컬 DNS 서버로 사용하고 있고 제 서버의 IP를 가리키는 seafile.local에 대한 레코드를 추가한 다음 이 도메인을 시스템 관리자 URL 설정에 넣었고 즉시 파일을 업로드할 수 있었습니다.

 

프로 버전 설치 참고 - https://manual.seafile.com/docker/pro-edition/deploy_seafile_pro_with_docker/

 

Seafile Professional Installation - Seafile Admin Manual

Deploy Seafile-pro with Docker Getting started Install docker Seafile v7.x.x (or newer versions) image uses docker. You should first install docker. Install Docker Engine on CentOS Install Docker Engine on Ubuntu Install docker-compose Seafile v7.x.x image

manual.seafile.com

 

728x90

출처 : https://garamchoi.tistory.com/416

 

[2022.08.13 시행] 제20회 정보보안 기사 실기 가답안

[단답형] 1. 텔넷으로 HTTP METHOD를 확인하는 방법 정답 : OPTIONS 2. 정량적 위험분석방법 정답 : 델파이법, 시나리오법, 순위결정법 3. 위험분석 접근법 정답 : 베이스라인(기준선) 접근법, 상세 위험

garamchoi.tistory.com

 

[단답형]
1. 텔넷으로 HTTP METHOD를 확인하는 방법
정답 : OPTIONS
2. 정량적 위험분석방법
정답 : 델파이법, 시나리오법, 순위결정법
3. 위험분석 접근법
정답 : 베이스라인(기준선) 접근법, 상세 위험 분석, 복합(통합) 접근법
4. 접근통제 방법
정답 : DAC, MAC, RBAC
5. 빈칸 집어넣기
정답 : 오탐(FALSE POSITIVE), 미탐(FALSE NEGATIVE)
6. IPSEC에서 지원하는 기능(서비스) 3가지
정답 : 기밀성, 비연결형 무결성, 재전송 공격방지
7. 비트코인
정답 : 비트코인, 블록체인, 채굴
8. 디렉터리 리스팅 취약점 옵션제거
정답 : INDEXES
9. ns 서브도메인에 cname할당 후 서브도메인 사용하지않는데 cname을 삭제하지 않는경우 서브도메인 피싱 등 사이트로 이용될수 있다. 이 취약점은 무엇인가
정답 : 서브도메인 테이크오버
10. 물리적 정보보호 대책
정답 : ① 각종 잠금장치
② 방문자 기록 및 동행
③ 직원의 신원 보증 및 신분증 배지(badge)
④ 경비원 및 감시카메라
⑤ 방문자 접근의 통제
⑥ 중요 구역의 이중 출입문 설치
⑦ 민감한 시설의 위치
⑧ 컴퓨터 단말기 잠금장치
⑨ 단일 출입구 및 경보시스템

[서술형]
11. 개인정보 수집 이용 가능한 4가지
정답 : 1. 정보주체의 동의를 받은 경우
2. 법률에 특별한 규정이 있거나 법령상 의무를 준수하기 위하여 불가피한 경우
3. 공공기관이 법령 등에서 정하는 소관업무의 수행을 위하여 불가피한 경우
4. 정보주체와의 계약의 체결 및 이행을 위하여 불가피하게 필요한 경우
5. 정보주체 또는 그 법정대리인이 의사 표시를 할 수 없는 상태에 있거나 주소불명 등으로 사전 동의를 받을 수 없는 경우로서 명백히 정보주체 또는 제3자의 급박한 생명, 신체, 재산의 이익을 위하여 필요하다고 인정되는 경우
6. 개인정보처리자의 정당한 이익을 달성하기 위하여 필요한 경우로서 명백하게 정보주체의 권리보다 우선하는 경우. 이 경우 개인정보처리자의 정당한 이익과 상당한 관련이 있고 합리적인 범위를 초과하지 아니하는 경우에 한한다.

12. 스위칭 허브의 기능 및 동작 원리
정답 :
스위칭 허브 기능 : 물리적 주소를 구분하여 해당 주소가 있는 포트로 데이터를 보내주는 장비
장점 : 콜리전 도메인을 나눠줌, 속도가 빠름
단점 : 테이블에 없는 목적지를 가진 패킷이 오면 모든 포트에 플러딩 하므로 트래픽이 많아짐
스위칭 허브 동작원리
1) Learning - Mac 주소 기반 MacAddress Table 학습
2) Flooding - Mac 주소가 MacAddress Table에 없을 경우 들어온 포트를 제외한 모든포트에 Broadcast
3) Fowarding - 목적지 주소에만 프레임을 전달
4) Filtering - 확인된 포트를 제외한 나머지 포트로 프레임 전달 방지
5) Aging - MacAddress Table의 효율적인 관리를 위해 일정시간 후 삭제

13. ids 룰 + 탐지결과 주고 공격자가 어떤 원리 이용해서 공격했는지
정답 : anonymous ftp
alert tcp any any -> any 21
{content:”anonymous”; nocase; msg:”Anonymous FTP 꿍시렁 꿍시렁”;}
snort룰 입니다.
저거로 탐지되는 거는 ftp포트(tcp21)로 들어오는 패킷 중 패킷페이로드에 대소문자 구분 없이 anonymous가 있냐 없냐를 보는 거기 때문에 탐지된 패킷에서 보면 USER 계정에 대소문자 섞어서 AnOnYmOuS 가 있었기 때문에 alert action이 수행된 거라고 봅니다.

[실무형]
14. mtp 릴레잉 deny관련.
smtp 릴레잉 deny관련
1./etc/mail/() | grep r*s$ | relaying denied
2. cat /etc/mail/access
span.com ()
3. () hash etc/mail/() < etc/mail/access
정답 :
1. access

2. reject
3. makemap
4. access.db
15. smurf attck 방지를 위한 라우터 설정을 순서대로 쓰시오
정답 :
conf t
int fa0/0 (인터페이스 예시)
no ip directed-broadcast 순입니다.
16.
1.위험수용의 의미
2.위험감소는 보안대책을 구성하는데,특정 보안대책의 평가기준을 결정하는 정량적인 방법
3.위험회피시 위험이있는 프로세스나 사업은 어떻게 대처하는지
4.위험인가 방법 2가지

1. 위험수용 이란 감수할만한 위험이라 판단하고 프로세스 및 사업을 진행하는 것
2. 재산가치x노출계수 (아닌듯)
3. 위험회피시 위험이 있는 프로세스나 사업은 포기 및 다른 프로세스, 사업으로 대체한다.
4. 보험가입, 위탁업체 선정

728x90

728x90

enable
conf t
mirdate(config)#hostname mirdate (호스트명 mirdate로 설정하기)
mirdate(config)#no hostname (호스트명 취소하기)

DNS서버 명령어 찾지않기
mirdate(config)#no ip domain-lookup

로깅 싱크설정스위치에서 설정작업을 하다보면 명령어 입력도중 시스템 관련메시지가 자동으로 표시되므로 명령어를 제대로 입력하기 위해 싱크작업을 한다
mirdate(config)#line 0 16
mirdate(config-line)#logg sync

콘솔접속 유지하기
mirdate(config)#line console 0 
mirdate(config-line)# exec-timeout 0

패스워드 설정
mirdate(config)# enable secret cisco
해당명령어는 관리자 패스워드를 cisco 로 설정하겠다는 뜻이다

라인상황 확인하기
mirdate#show line

라인상황을 확인후 VTY 설정을 한다
mirdate(config)#line vty 0 15
mirdate(config-line)# password cisco
이러면 원격접속 라인 0~ 15까지 라인의 패스워드가 cisco 로 설정된다

vty 패스워드는 암호화 되지 않았기에 암호화를 한다
mirdate(config)#service password-encryption

.VLAN 1에 IP 할당하기
mirdate(config)#int vlan 1
mirdate(config)#ip address 10.10.10.10 255.255.255.0
mirdate(config)#no shutdown (포트 활성화)

설정 저장
mirdate(config)#do write memory

컨피그 확인 방법
mirdate#show running-config

배너달기
mirdate(config)#banner motd *Authonized access only!!*시작전후 *을쓴다

한글배너 입력하기
mirdate(config)# default-value exec-character-bits 8
mirdate(config)# banner motd *비인가자의 접속을 엄금합니다!!*
mirdate(config)#

인터페이스 설명달기
mirdate(config)# interface f 1/0/1
mirdate(config)# description mirdate1
mirdate(config)# interface f 1/0/2
mirdate(config)# description mirdate2

기본설정파일 셋팅
enable
config terminal
no ip domain-lookup
enable secret $gm@te2oo8

alias exec c config terminal
alias exec r show running-config
alias exec i show ip route
alias exec b show ip interface breif

line consol 0
logging synch
exec-timeout 0
lin vty 0 5pass $gm@te2oo8
exit
hostname

NTP 서버 주소
time.bora.net
time.nist.gov
time.windows.com
time.google.com

CISCO 장비 시간 확인 명령
mirdate#sh clock
.07:37:23.322 UTC Tue Jun 29 2010

CISCO 장비 시간대 설정 변경
mirdate#conf t
mirdate(config)#clock timezone KST 9
mirdate(config)#exit
mirdate#wr
mirdate#sh clock
.16:39:10.918 KST Tue Jun 29 2010

CISCO 장비 시간 설정
mirdate#clock set 22:25:00 29 jun 2010

CISCO 장비 NTP 설정
mirdate#conf t
mirdate(config)#ntp server [서버IP주소]
mirdate(config)#exit
mirdate#wr

 

빠른 스패닝트리 설정

mirdate#conf t

mirdate(config)#spanning-tree mode rapid-pvst
mirdate(config)#spanning-tree portfast edge default
mirdate(config)#spanning-tree extend system-id

mirdate(config)#exit
mirdate#wr

mirdate#show running-config 로 확인

728x90

원문출처 : https://positive2357.tistory.com/104

 

윈도우10 정상 종료시 화면은 꺼지고 종료는 안될 때

오래전부터 발생한 문제라 하던데요. 최근 윈도우 업데이트를 하고 발생한 문제입니다. 그 전에는 없던 문제였습니다. 정상적으로 종료를 하였는데도 모니터는 꺼졌고 팬과 하드 소리, 전면에

positive2357.tistory.com

 

오래전부터 발생한 문제라 하던데요.
최근 윈도우 업데이트를 하고 발생한 문제입니다. 그 전에는 없던 문제였습니다.
정상적으로 종료를 하였는데도 모니터는 꺼졌고 팬과 하드 소리, 전면에 불은 계속 켜져 있었어요. 본체는 꺼지지 않았습니다.
전원 버튼으로 재부팅을 하고 종료하면 정상적으로 꺼졌어요. 혹여 메인보드나 모니터에 이상이 있는 줄 알고 불안했어요.

윈도우10 정상종료 시 종료가 안 될 때

절전에 관한 문제라 하던데요.
최대 절전모드는 사용하고 있긴 한데 그에 관련된 문제점인지 다른 것과 충돌 때문인지. 정확하게 잘 모르겠습니다.

MS의 설명을 보자면 이렇습니다.

절전은 전력 소모가 거의 없고 PC 시작 속도가 빨라서 마지막으로 종료한 부분에서 즉시 이어서 작업할 수 있습니다. 배터리 잔량이 부족할 경우 Windows가 모든 작업을 자동으로 저장하고 PC를 끄기 때문에 사용자는 배터리 소모로 인한 작업 손실 걱정 없이 작업을 수행할 수 있습니다. 커피를 마시며 휴식을 취하는 경우와 같이 잠시 동안 PC를 사용하지 않을 경우 절전 모드를 사용합니다.

최대 절전 모드에서는 절전 모드보다 적은 전원을 사용하며 PC를 다시 시작하면 종료된 부분으로 돌아가지만 절전 모드만큼 빠르지는 않습니다. 이 옵션은 노트북용으로 설계되었으며 일부 PC에는 사용할 수 없습니다.

그냥 절전 기능만 써야 되겠다는 생각이 드네요.

해결 방법 ①최대 절전모드 해제 (cmd 검색 - 명령 프롬프트 관리자 권한 실행)

최대 절전 모드를 해제할 때 : powercfg.exe /hibernate off
최대 절전모드를 다시 사용하고 싶을 때 : powercfg.exe /hibernate on

해결방법 ② 설정-시스템-전원 및 절전-추가 전원 설정-전원 단추 작동 설정-현재 사용할 수 없는 설정 변경-종료 설정의 빠른 시작 켜기(권장) 체크 해제

시작 - 설정 - 시스템

 

윈도우시작/설정

 

전원 및 절전 - 추가 전원 설정 - 전원 단추 작동 설정

 

전원 및 절전 설정

 

빠른 시작 켜기에 체크되어 있을 텐데요. 현재 사용할 수 없는 설정 변경을 클릭합니다.

 

제어판 전원옵션 시스템설정

 

종료 설정

빠른 시작 켜기(권장)을 체크 해제 - 변경 내용 저장

 

 

정상적으로 시스템 종료를 하고 모니터는 꺼졌는데 PC는 계속 켜져 있었던 문제를 해결했습니다.

728x90

리눅스 OS(Redhat, Debian, Ubuntu 등 리눅스 기반 운영체제)가 설치된 서버에서 현재 사용 중인 메모리 사용량을 확인하고 캐시 메모리 사용량이 많은 경우 이를 비워서 시스템 효율을 높이는 방법입니다. 명령어 기반으로 터미널에서 간단히 사용할 수 있습니다.


메모리 사용량 확인 명령어
$  free -m

pagecache 해제 명령어
$  echo 1 > /proc/sys/vm/drop_caches

dentry 및 inode 캐시메모리 해제 명령어
$ echo 2 > /proc/sys/vm/drop_caches

pagecache, dentry, inode 캐시메모리 모두 해제 시
$ echo 3 > /proc/sys/vm/drop_caches

크론탭(crontab)을 사용하여 시스템이 주기적으로 메모리 관리
$ crontab -e
크론탭 편집 모드에서 아래와 같이 입력

0 3 * * * sync && echo 3 > /proc/sys/vm/drop_caches
위의 명령어는 매일 새벽 3시에 시스템이 자동으로 전체 캐시 메모리를 비우는 명령어로 시간대는 원하는 때로 변경 가능

00 */2 * * * sync && echo 3 > /proc/sys/vm/drop_caches
매 2시간 마다 캐시 메모리 정리 명령어 자동 실행

용어 참고
- pagecache : 파일의 입출력(I/O)의 속도와 퍼포먼스를 높이기 위해 시스템이 할당한 메모리 영역(임시 메모리 저장소). 예를 들어 어떤 경로의 파일을 한 번 읽어들이면 시스템이 해당 파일 내용을 임시메모리에 저장시키는데 이후에 해당 파일을 다시 읽을 때 이를 새로 읽어들이지 않고 이 메모리에서 바로 불러오면 디스크의 읽기/쓰기 속도가 빨라지므로 효율이 높아짐. 윈도우 OS의 페이지 파일 같은 역할.

- dentry : directory entry의 줄임말로 예를 들어 /usr/share 같은 경로에서 usr과 share를 지칭.

- inode : 파일과 디렉토리에 관한 정보를 담고 있는 자료구조. 예를 들어 파일의 퍼미션 정보, 디스크 상의 파일의 물리적 위치, 크기, 생성된 일시 정보 등을 저장.

728x90

원문출처 : https://www.2cpu.co.kr/vm/13805

 

ESXi 부팅용 USB 혹시 복사 되나요? :: 2cpu, 지름이 시작되는 곳!

1/115

www.2cpu.co.kr

 

질문 :
안녕하세요.

현재 ESXi 5.5u2를 SD카드에 설치해 사용 중입니다.

오랜만에 최신버전으로 업데이트 해보려니 용량이 모자란다는 메시지가 나오고, 32기가가 넘어야 된다고 하네요.

클린 설치하려니 막막해서 이곳 고수님들께 여쭤봅니다.



질문1) 혹시 ESXi 부팅용 USB도 복사해서 부팅시킬 수 있나요?

질문2) (가능하다면) 일반적인 usb 클론 툴로 가능한가요? 아니면 혹시 추천해주실만한 어플리케이션이 있는지 여쭤봅니다.


답변 :
ESXi Configuration 백업 후에 32GB 이상의 SD(다른 저장매체에 해도 됨)에 동일 버전으로 재 설치, 그리고 복원 하시면 됩니다.
주의 사항으로는 Build 버전까지 동일 한 버전으로 재 설치 하셔야 하며, 기존에 추가 등록한 VIB가 있는 경우에는 별도로 수동 설치 해야 합니다.

방법은 아래 링크를 참고 하시면 됩니다.
https://kb.vmware.com/s/article/2042141

정리하면 아래와 같습니다.

ESXi에 SSH으로 접근 후에
1. vim-cmd hostsvc/firmware/sync_config 실행
2. vim-cmd hostsvc/firmware/backup_config 실행.
3. http://Host_FQDN/downloads/xxxxxxxxxxx/configBundle-xx.xx.xx.xx.tgz 다운로드
4. 재 설치.
5.vim-cmd hostsvc/maintenance_mode_enter 으로 유지보수 모드 진입
6.다운로드한 configBundle-xx.xx.xx.xx.tgz 업로드
7.vim-cmd hostsvc/firmware/restore_config /backup_location/configBundle-xx.xx.xx.xx.tgz 실행으로 복원
그리고 재부팅.

728x90

정부문서표준양식예제.zip
1.11MB

728x90

원문출처 : https://0muwon.com/entry/%EC%8B%A0%EA%B7%9C-%EA%B3%B5%EB%AC%B4%EC%9B%90%EC%9D%84-%EC%9C%84%ED%95%9C-%EA%B3%B5%EB%AC%B8%EC%84%9C-%EC%9E%91%EC%84%B1-%EB%B0%A9%EB%B2%95-%EA%B8%B0%EC%B4%88%ED%8E%B8-2%ED%83%84

 

신규 공무원을 위한 공문서 작성 방법 기초편 2탄

신규 공무원을 위한 올바른 공문서 작성 방법 기초편 2탄입니다. 문장의 의미를 빠르고 정확하게 전달하기 위해 띄어쓰기를 잘 해야 합니다. 공문에서도 중요한 부분 중 하나입니다. 띄어쓰기를

0muwon.com

신규 공무원을 위한 올바른 공문서 작성 방법 기초편 2탄입니다. 문장의 의미를 빠르고 정확하게 전달하기 위해 띄어쓰기를 잘 해야 합니다. 공문에서도 중요한 부분 중 하나입니다.

 

띄어쓰기를 하지 않거나 잘못하면 의미가 잘못 전달될 수 있습니다. 인터넷에서 웃긴 띄어쓰기라고 검색하면 나오는 도로표지판입니다. "동시흥분기점" 입니다. 물론 지금은 "동시흥 분기점"으로 변경되어 있습니다.

 

▼ 변경 전

 

 

동시흥분기점

 

 

▼ 변경 후

 

 

동시흥 분기점

 

 

이렇게 같은 말이리도 띄어쓰기에 따라 완전 의미가 달라집니다. 오늘은 띄어쓰기 요령에 대해서 알아보도록 하겠습니다.

 

1. 띄어쓰기 기본 원칙

띄어쓰기 기본 원칙은 "문장의 각 단어는 띄어 씀을 원칙으로 한다." 입니다. 서로 다른 단어는 띄어 쓰는 것이 띄어쓰기의 기본 원칙입니다. 다만, 합성어는 하나의 단어이므로 띄어 쓰지 않고 붙혀 씁니다.

 

 

띄어쓰기 기본 원칙

 

 

예를 들면,

완료예정은 완료∨예정, 업무계획은 업무∨계획, 추진실적은 추진∨실적으로 띄어쓰기 합니다.

 

 

각 단어 띄어쓰기

 

2. 띄어쓰기 규정 11개

띄어쓰기 규정입니다. 기본원칙을 포함 11개 항이 있습니다. 아래 이미지를 저장해 놓고 계속 보시기를 추천합니다. 중요한 몇가지만 자세히 알아보도록 하겠습니다.

 

 

띄어쓰기 규정

 

3. '조사'의 띄어쓰기

조사는 그 앞 말에 붙여 씁니다.

"이/가", "을/를", "에게", "", "도", "마저", "처럼" 등 조사는 그 앞 말에 붙여 씁니다. "학교에서만이라도"와 같이 조사가 연속적으로 붙는 경우에도 조사는 모두 앞 말에 붙여 씁니다. 

 

 

조사 띄어 쓰는 방법

 

4. '의존 명사'의 띄어쓰기

의존 명사는 띄어 씁니다. "간", "내", "‘외", "‘중", "시", "‘데", "‘바", "대로", "만큼", "뿐", "채" 등 의존명사는 앞 말과 띄어 씁니다. 의존명사는 조사와 구별하는 것이 쉽지는 않아 더 주의가 필요합니다.

 

 

예를 들어, "만큼", "뿐"은 의존명사인 경우에는 "아는 만큼", "공부를 잘할 뿐만 아니라"와 같이 띄어 씁니다. 하지만, 조사로 사용하는 경우에는 "지식만큼", "공부뿐만 아니라"와 같이 붙여 씁니다.

 

 

의존 명사 띄어 쓰는 법

 

 

단, "이틀간/한 달간/삼십 일간" 등과 같이 "동안"을 나타내는 말은 접미사이므로 붙여 써야 합니다.

5. '단위 명사'의 띄어쓰기

단위를 나타내는 명사는 띄어 씁니다. 따라서 "차 한 대", "연필 한 자루", "한 개", "집 열 채"와 같이 띄어 씁니다. 제일 많이 틀리게 쓰는 것 중 하나가 금액을 쓸때입니다. 금액을 쓸 때 "일만원"으로 쓰지만, "일만 원"이 올바른 띄어쓰기 입니다. "일만 원"으로 작성하면 "일만원"으로 수정하는 경우도 많이 있습니다.

 

 

단위 명사 띄어 쓰는 법

 

6. '수'의 띄어쓰기

수를 적을 때에는 "만" 단위로 띄어 씁니다. 수는 "십오억 오천사백육십이만 팔천구백사십사", "12억 5462만 8944"과 같이 만 단위로 띄어 씁니다.

 

7 '이름'의 띄어쓰기

성과 이름, 성과 호 등은 붙여 쓰고, 이에 덧붙는 호칭어, 관직명 등은 띄어 씁니다.

예를 들어, "성과 이름 : 홍길동", "성명과 호칭어 : 이하니 박사, 김마리아 씨", "성과 관직명 : 이순신 장군" 처럼 씁니다. 다만, 다만 성과 이름, 성과 호를 분명히 구분할 필요가 있는 경우에는 ‘남궁 민’, ‘황보 혜정’과 같이 띄어 쓸 수 있습니다.

 

띄어쓰기 규정 중 몇가지만 알아보았습니다. 띄어쓰기 규정만으로 띄어쓰기를 다 잘할 수는 없습니다. 계속 연습하는 수 밖에는 없습니다. 그리고 궁금한 사항이 있다면 "국립국어원 홈페이지"를 이용해 보시기 바랍니다.

728x90

원문출처 : https://0muwon.com/entry/%EC%8B%A0%EA%B7%9C-%EA%B3%B5%EB%AC%B4%EC%9B%90%EC%9D%84-%EC%9C%84%ED%95%9C-%EA%B3%B5%EB%AC%B8%EC%84%9C-%EC%9E%91%EC%84%B1-%EB%B0%A9%EB%B2%95-%EA%B8%B0%EC%B4%88%ED%8E%B8

 

신규 공무원을 위한 공문서 작성 방법 기초편

공문서는 행정 업무처리를 위해 대내외적으로 발송, 수신하는 공식적인 문서이기 때문에 형식적인 부분도 중요합니다. 경력이 짧은 신규공무원의 경우 공문서 작성이 어려울 수 있는데요. 오늘

0muwon.com

공문서는 행정 업무처리를 위해 대내외적으로 발송, 수신하는 공식적인 문서이기 때문에 형식적인 부분도 중요합니다. 경력이 짧은 신규공무원의 경우 공문서 작성이 어려울 수 있는데요. 오늘은 신규공무원을 위한 공문서 작성 방법을 알아보도록 하겠습니다.

 

공문서 작성 방법

1. 항목의 표시

문서의 내용을 둘 이상의 항목으로 구분할 필요가 있으면 다음 구분에 따라 그 항목을 순러대로 표시하되, 필요한 경우에는 □, ○, ―,  ˙ 등과 같은 특수한 기호로 표시할 수 있습니다.

 

 

 

 

▼ 항목 순서

1 → 가 → 1) → 가) → (1) → (가) → ① → ㉮ 순서입니다. "가", "가)", "(가), "㉮" 의 경우 하, 하), (하), ㉻ 이상 계속되는 때에는 거, 거), (거) 순서로 표시합니다.

 

공문서 항목의 표시

2. 표시위치 및 띄우기

가. 첫째 항목기호는 왼쪽 처음부터 띄어쓰기 없이 바로 시작합니다.

나. 둘째 항목부터는 상위 항목 위치에서 오른쪽으로 2타씩 옮겨 시작합니다.

다. 항목이 한줄 이상인 경우에는 항목 내용의 첫 글자에 맞추어 정렬을 합니다. shift + Tab키를 사용하면 됩니다.

라. 항목기호와 그 항목의 내용 사이에는 1타를 띄웁니다.

마. 하나의 항목만 있는 경우에는 항목기호를 부여하지 않습니다.

※ 1타(∨ 표시)는 영문 1자, 숫자 1자, 2타(∨∨ 표시)는 한글 1자에 해당합니다.

 

공문서 항목기호 표시위치 및 띄우기

 

바. 하나의 본문아래 항목을 구분하는 경우

하나의 본문에 이어서 항목이 나오는 경우 항목의 순서 및 띄어쓰기 방법입니다.

 

 

 

 

1) 첫째 항목은 1., 2., 3., ... 등 부터 시작을 합니다.

2) 첫째 항목은 왼쪽 한계선에서 시작을 합니다.

 

공문서 하나의 본문아래 항목구분하는 경우

 

3. 날짜, 시간, 금액의 표시

가. 날찌는 연, 월, 일 생략 후 그 자리에 마침표를 찍어 표시합니다.

 

날짜의 표시 방법

 

 

나. 시간은 24시각제에 따라 쌍점(:)을 사용하여 숫자료 표기합니다. 시, 분의 글자는 생략합니다.

 

시간의 표시 방법               

 

다. 금액은 숫자 다음에 괄호를 하고 한글로 기재합니다.

 

금액의 표시 방법

4. 첨부물(붙임)의 표시

가. 본문이 끝난 다음에 붙임을 표시합니다.

나. 첨부물이 2개 이상일 때 1, 2, 3 등 숫자로 항목을 구분하여 표시합니다.

다. "붙임"의 글자를 "붙 임" 등으로 띄어 쓰거나 붙임 뒤에 쌍점(:)을 찍지 않습니다.

 

첨부물, 붙임의 표시 방법

 

 

 

5. 문서의 "끝" 표시

가. 본문 내용이 마지막 글자에서 한 글자(2타) 띄우고 "끝" 표시를 합니다.

 

문서의 "끝" 표시

 

나. 첨부물이 있으면 붙임 표시문 다음에 한 글자(2타) 띄우고 "끝" 표시를 합니다.

 

첨부물 있는 문서의 경우

 

다. 본문 또는 붙임 표시문이 오른쪽 한계선에서 끝났을 경우에는 그 다음 줄의 왼쪽 한계선에서 한 글자(2타) 띄우고 "끝" 표시를 합니다.

 

본문이 오른쪽 한계선에서 끝난 경우

 

라. 본문이 표로 끝나는 경우, 표 아래 왼쪽 한계선에서 한 글자(2타) 띄우고 "끝"자를 표시합니다.

 

본문이 표로 끝나는 경우

 

마. 표의 중간에서 기재사항이 끝나는 경우, 기재사항의 마지막 다음 줄에 "이하 빈칸"이라고 표시합니다.

 

표의 중간에서 끝나는 경우

 

공문서 작성 시 도움이 되길 바랍니다.

728x90

원문출처 : https://0muwon.com/entry/%EC%8B%A0%EA%B7%9C-%EA%B3%B5%EB%AC%B4%EC%9B%90-%EB%A9%8B%EC%9E%88%EB%8A%94-%EB%B3%B4%EA%B3%A0%EC%84%9C-%EC%9E%91%EC%84%B1%EC%9D%84-%EC%9C%84%ED%95%9C-%ED%95%9C%EA%B8%80-%EA%B8%B0%EB%B3%B8-%EC%84%A4%EC%A0%95%ED%95%98%EA%B8%B0-1%ED%83%84

 

신규 공무원, 멋있는 보고서 작성을 위한 한글 기본 설정하기 1탄

다른 사람이 작성한 문서를 취합을 하는 경우, 문서마다 다른 설정으로 인해 편집하는데 많은 시간을 소비하게 됩니다. 막상 내용보다는 양식 맞추는데 시간이 걸려 힘들 때가 있습니다. 그렇기

0muwon.com

다른 사람이 작성한 문서를 취합을 하는 경우, 문서마다 다른 설정으로 인해 편집하는데 많은 시간을 소비하게 됩니다. 막상 내용보다는 양식 맞추는데 시간이 걸려 힘들 때가 있습니다. 그렇기 때문에 가급적 문서의 기본설정을 동일하게 맞추어 사용하는게 좋습니다. 문서의 통일성도 있고, 효율도 높아집니다.

 

신규공무원들을 위해 오늘은 그 중에서도 가장 기본적인 한글 설정을 알아보도록 하겠습니다. 설정할게 생각보다 많은거 같아 나누어서 작성을 합니다. 편집용지 설정, 스타일 정리, 기본글꼴 휴먼명조로 설정, 휴먼명조 글꼴정리, 겹낫표 사용 설정,  상용구 등록 등을 차례대로 알아보도록 하겠습니다. 한번 따라서 설정해 보시기 바랍니다.

 

 

한글 기본 설정하기

 

1. 사용 전 기본 설정

▼ 용지 여백

가장 먼저 한글문서의 편집 용지를 설정하는 방법입니다. 한글문서의 편집 용지 기본설정은 여백이 많습니다. 보고서 등 문서를 작성할 때 여백을 조정하여 사용합니다. 용지 여백을 통일하는게 매우 중요합니다. 여백이 다른 경우 문서 모양 자체가 완전 달라집니다.

 

도구 > 파일 > 편집 용지 > 기본 에서 용지여백을 조정합니다. A4 기준입니다. 위쪽여백 15, 머리말 10, 왼쪽 20, 오른쪽 20, 꼬리말 10, 아래쪽 10 입니다. 아래쪽 여백을 15를 주어도 상관은 없습니다. 이게 정답은 아닙니다만, 일반적으로 많이 사용합니다. 기관마다 정해진 편집 용지 설정이 있다면 그걸 사용하면 됩니다.

 

 

편집 용지 설정하기

 

 

▼ 스타일 정리

 

문서의 스타일을 정리합니다. 스타일에 따라서 모양이 달라질 수 있습니다. 바탕글을 제외하고 모두 삭제를 해서 사용을 합니다. 특이한 스타일을 만들어서 사용하는 분들도 많이 있습니다만, 가급적 심플한 스타일로 작성하는게 좋습니다. 다른 사람의 문서를 취합하거나 수정할 때 스타일 때문에 시간이 많이 걸릴 수 있습니다.

 

서식 > 스타일 > 스타일 내보내기 > 파일 선택 > Normal(한글기본 스타일) > 바탕글 제외하고 모두 삭제 > 닫기 > 저장으로 스타일을 정리합니다. 한글 2010, 2018 등 버전에 따라 조금 차이는 있을 수 있습니다만, 방법은 동일합니다.

 

 

스타일

 

 

스타일 화면에서 하단의 디스크 모양을 클릭하여 스타일 내보내기를 합니다.

 

 

스타일 내보내기

 

 

파일 선택에서 한글 기본 스타일을 설정합니다. 한글 2010 버전에서는 normal을 선택하면 됩니다.

 

 

스타일 내보내기 파일 선택

 

 

그러면, 좌측에 스타일이 생깁니다. 여기에서 바탕글을 제외하고 모두 삭제를 합니다.

 

 

한글 기본 스타일

 

 

다른 스타일은 삭제한 화면입니다. 닫기 버튼을 클릭하여 저장을 합니다.

 

 

바탕글 제외하고 삭제

 

 

스타일 저장 버튼을 클릭합니다.

 

 

저장을 합니다.

 

 

스타일이 바탕글을 제외하고 모두 삭제 되었습니다. 저장을 완료하였는데도 스타일 목록이 기존과 같다면 하단의 폴더모양을 클릭하여 스타일을 가져옵니다. 가져오기 화면에서 한글 기본 스타일을 선택합니다.

 

 

스타일 목록을 확인하세요

 

 

▼ 휴먼명조 글꼴 정리하기

휴먼명조 글꼴에는 TTF와 HTF가 있으면 서로 글꼴의 차이가 있습니다. 그래서 같은 휴먼명조로 작성하더라도 글자체가 다를 수 있습니다. 한글에서 사용하는 글꼴은 HTF 입니다. 그래서 TTF는 삭제를 하여야 합니다. 이것은 지난번에 자세하게 작성을 하였습니다.  그 글을 참고하세요.

 

- 휴먼명조 다르게 보이는 경우, 휴먼명조체 글꼴 오류 조치방법

 

▼ 겹낫표 (「」) 설정하기

 

문서를 작성하다보면 겹낫표를 은근히 많이 사용을 합니다. 보통 ctrl + f10키를 눌러 문자표를 클릭 후 겹낫표를 입력합니다. 하지만, 입력기 환경 설정에서 겹낫표 입력을 체크하면 쉽고 간편하게 겹낫표를 입력할 수 있습니다.

 

 

입력기 환경 설정

 

 

‘Alt+F2’(입력기 환경설정) > 기타(탭) > 겹낫표 입력을 체크합니다. 사용법은 간단합니다. 겹낫표를 입력하고자 하는 곳에 커서를 위치한 후 "shift + [" 또는 "shift + ]" 를 누릅니다.

 

설정이 완료되었다면, 낫표 (「」) 도 간편하게 입력이 됩니다. 그냥 "대문자괄호 [ " 또는 "대문자괄화 ]" 를 누르기만 하면 됩니다.

 

 

겹낫표, 낫표 입력

 

 

▼ 상용구 등록

가운데 점, 연도 등 자주 사용하는 상용구를 미리 등록해서 사용하면 편합니다. 가운데 점과 연도 등을 상용구에 등록해보도록 하겠습니다.

 

ctrl + f3을 누르면 상용구 등록창이 나옵니다. + 버튼을 클릭하여 상용구를 등록합니다. 준말에 가운데 점을 일력 후 본말에는 · (middle dot)을 입력합니다. 가운데 점은 ctrl + f10을 눌러 문자표에서 HNC 입력탭에서 HNC코드에서 0027을 입력하면 됩니다. ▼ 한글 엑셀 등 문서 작성 시 가운데 점 (˙) 쉽게 찍는 법

 

 

연도의 경우는 같은 방식으로 입력을 합니다. ctrl + f10를 누른 후 문자표에서 유니코드 탭에서 유니코드에 2027을 입력하면 됩니다.

 

 

상용구 등록하기

 

 

▼ 기타 환경설정

표를 작성할 때 많이 쓰이는 기능입니다. "표 안에서 <Tab>으로 셀 이동"에 체크를 하여야 표 안에서 탭으로 이동이 가능합니다. 도구 > 환경설정 > 편집탭에서 체크를 합니다.

 

그리고 문서를 작성하다 보면 가끔 '수정' 상태로 변경이 되어 글자를 입력하면 삭제가 되면서 수정이 되는 경우가 생깁니다. 이 것을 방지하기 위하여 '삽입 잠금'을 체크합니다. 그러면 항상 삽입으로만 글자를 입력할 수 있습니다. 한글 2010 버전에서는 기타 탭에서 설정이 가능합니다.

 

 

환경설정

 

 

오늘은 여기까지 정리합니다. 다음 편을 기대해 주세요. 실무에 사용하기 좋은 팁입니다.

728x90

원문출처 : https://blog.dalso.org/article/esxi-rdm-raw-device-mapping

 

ESXi RDM(Raw Device Mapping) 사용하기. - 헤놀로지 사용시 추천 - 달소씨의 하루

이번편에서는 ESXi를 좀더 효율적으로 사용하기위한 RDM(Raw Device Mapping)을 사용하는 방법에 대해 포스팅해보도록 하겠습니다. RDM이란 ESXi에서 사용이 가능한 원시 디스크를 의미합니다.원시디스

blog.dalso.org

 

ESXi RDM(Raw Device Mapping) 사용하기. – 헤놀로지 사용시 추천

 

이번편에서는 ESXi를 좀더 효율적으로 사용하기위한 RDM(Raw Device Mapping)을 사용하는 방법에 대해 포스팅해보도록 하겠습니다.

RDM이란 ESXi에서 사용이 가능한 원시 디스크를 의미합니다.
원시디스크는 디스크를 데이터스토어로 만들지않고 날것(?) 그대로 저장장치로 사용해서 가상머신에 붙이는걸 의미합니다.

이런 RDM을 사용하게되었을때 이점은 데이터스토어의 vmdk파일처럼 분리되어있지 않기때문에 헤놀 -> 시놀, 시놀 -> 헤놀의 과정을 거쳤을때 불필요한 여러번의 과정을 줄여줍니다.

HDD 장치 자체를 가상머신에 매핑해주기때문에
시놀로지에서 사용하던 HDD를 ESXi에 꽂고 RDM으로 매칭후 헤놀을 만들게 되면 시놀로지에서 사용하던 그대로 붙게되는것 입니다.

ESXi SSH 사용 설정하기

RDM을 설정하기위해서는 ESXi에 SSH로 콘솔을 붙어야하기 때문에 SSH 활성화를 먼저 해주겠습니다.

접속프로그램은 Putty를 사용해서 붙겠습니다.

계정은 ESXi 웹 콘솔 접근 계정과 동일합니다.

RDM 적용 디스크 확인

이제 RDM을 적용할 디스크를 확인할 차례입니다.

ls /dev/disks/ -l 명령어로 디스크 목록을 볼 수 있습니다.
명령어 결과에서 심볼릭링크로 되어있으며 뒤에 숫자가 없는걸 기록해주세요.
아래의 경우 vml.01000000002020202020202020202020205a44453252305837535431303030

RDM 적용하기

RDM도 원시 디스크를 -> vmdk 형식으로 링크화(?)시켜서 저장하는것이기 때문에 데이터스토어 저장되는데 저는 기본 datasotre1에 RDM이라는 폴더에 만들어보겠습니다.

vmkfstools -r /vmfs/devices/disks/[디스크이름] /vmfs/volumes/[데이터스토어이름]/[디렉토리]/[생성할RDM이름].vmdk -a lsilogic

위 명령어가 기본인데 제 기준으로 작성해보겠습니다.

디스크 이름 : vml.01000000002020202020202020202020205a44453252305837535431303030
데이터스토어 이름 : datastore1
디렉토리 : RDM
RDM이름 : Xpenology.vmdk

이걸 명령어로 나타내면 아래와 같습니다.

vmkfstools -r /vmfs/devices/disks/vml.01000000002020202020202020202020205a44453252305837535431303030 /vmfs/volumes/datastore1/RDM/Xpenology.vmdk -a lsilogic

그럼 이렇게 vmdk 파일이 생성되게 되고 VM 생성시에 기존 하드 디스크를 사용하면 자동으로 붙게됩니다.

 

————————————————–

 

+ Recent posts